それって本当に jQuery 必要?『You might not need jQuery』

インターネットコム / 2014年4月7日 14時30分

ちとマニアックだがなるほど、と思ったのでご紹介。

クロスブラウザのいろいろを気にしなくていいので、jQuery を使っている開発者は多いだろう。

しかし Internet Explorer 8 以下もだいぶ使われなくなってきたので、「そこ、別に jQuery じゃなくてもよくない?」と、あらためて考えてみてもいいだろう。

というわけで登場したのが「You might not need jQuery」だ。

このサイトでは「jQuery ではこう書くけど、IE8+ 対応だったらこうしてもいいんだよ」と教えてくれる。

確かにライブラリはいろいろ重くなるので、シンプルな処理だったらそれを使わずにすむに越したことはない。シンプルなコードを書くことが多い人は、覗いてみてもいいですね。

サイト名:You might not need jQuery
http://youmightnotneedjquery.com/

インターネットコム

トピックスRSS

ランキング